BENVENUTO!

Guida - Aggiornamento Mirato DCS da interfaccia grafica (no terminale)

Karma

Pilota
Registrato
30 Settembre 2012
Messaggi
6.761
Questa guida spiega come aggiornare DCS ad una versione specifica.

Di norma DCS aggiorna automaticamente all'ultima versione disponibile, però non sempre l'ultima versione disponibile è la migliore... Capita spesso che aggiornando il software vengano introdotti dei nuovi BUG, per questo lo Stormo è solito testare attentamente le nuove versioni del software prima di adottare ufficialmente una versione di DCS.

Se per un qualsiasi motivo ti dovessi trovare con una versione di DCS non compatibile con quella dello stormo e visto che l'auto-updater di DCS non ti consente di selezionare a quale versione aggiornare segui questa semplice guida ed in pochi semplici passi il problema sarà risolto. ;)


Premetto che ci sono 2 modi per indicare a DCS a quale versione aggiornare;
  • Nel primo si usa il terminale di Windows, quindi si istruisce il programma tramite linea di comando.
  • Nel secondo si usa crea un lanciatore da interfaccia grafica.

In questa guida tratteremo il secondo metodo, più semplice, più veloce ed adatto a tutti gli utenti. (anche Viking ed Eircog)  :D

Iniziamo!


1) Per prima cosa duplichiamo il lanciatore di DCS Single Player che abbiamo sul Desktop copiandolo ed incollandolo. Il risultato dovrebbe essere come quello mostrato nell'immagine successiva.

index.php


2) Cliccando col tasto destro del mouse sulla copia del collegamento appena creato, selezioniamo la voce "proprietà".  La finestra che si aprirà dovrebbe essere come la seguente:

index.php

Come si può vedere nell'immagine, la Destinazione del mio collegamento riporta "C:sneaky:DCS World\bin\DCS_updater.exe"
Probabilmente il il vostro collegamento avrà una destinazione diversa, dipende da dove avete installato DCS, in ogni caso non importa.



3) Per dire a DCS_Updater.exe di aggiornare dobbiamo aggiungere una funzione con relativi parametri opzionali alla fine della Destinazione.
Nell'immagine successiva vediamo il comando di aggiornamento generico che dirà a DCS_Updater.exe di aggiornare all'ultima versione disponibile:
"C:sneaky:DCS World\bin\DCS_updater.exe" update


index.php

Per aggiornare ad una versione specifica, ci basterà aggiingere la versione desiderata sotto forma di Parametro subito dopo la Funzione "update", in questo modo:

"C:sneaky:DCS World\bin\DCS_updater.exe" update 1.2.9

In questo modo aggiorneremo all'ultimo update della versione 1.2.9

Se volessimo installare un update differente dall'ultimo della versione di riferimento, ci basterebbe definirlo nel Parametro, in questo modo:

"C:sneaky:DCS World\bin\DCS_updater.exe" update 1.2.9.xxxxx (dove xxxxx stà per l'update desiderato)



4) Una volta aggiunta la funzione desiderata con relativi parametri alla Destinazione del collegamento, clicchiamo su OK per salvare le modifiche.

Ora ci basterà fare doppio click sul collegamento appena modificato per aggiornare DCS alla versione da noi scelta.

:cool:
 

Allegati

  • coll_coll.copia.jpg
    coll_coll.copia.jpg
    9,4 KB · Visite: 1.268
  • proprieta1.jpg
    proprieta1.jpg
    57,5 KB · Visite: 1.319
  • proprieta2.jpg
    proprieta2.jpg
    58,8 KB · Visite: 1.383
Bella! :)
 
Ottima! Grazie! ;)
 
Bravo kappa!

inviato dal bar di tziu pinucciu utilizzando un telefono a gettoni

 
Complimenti all' autore per l' ottima guida ;)

Solo una cosa , sperimentata di persona oggi durante la reinstallazione del World , e cioè che non occorre fare una copia dell' esegubile per avviare la procedura perchè basta semplicemente aggiungere la stringa che ci interessa , quindi "update 1.2.9" nelle proprietà di quello di default , una volta lanciato e aggiornato il sim alla versione voluta basta riandare in proprietà seguendo lo stesso percorso fatto in precedenza e togliere la stringa aggiunta , fatto finito.

Con questo metodo abbiamo il vantaggio che l' eseguibile rimane quello originario e non occorrono delle copie.. ;)

:)
 
Con questo metodo però quando lo lanci di nuovo ti richiederà se aggiornare all'ultimo update. Con il metodo di Karma non si ha questo inconveniente.
 
Pigon ha scritto:
Con questo metodo però quando lo lanci di nuovo ti richiederà se aggiornare all'ultimo update. Con il metodo di Karma non si ha questo inconveniente.

Anche per allacciarsi le scarpe ci sono diversi metodi, una volta capito il funzionamento uno sceglie quello che secondo lui è meglio.

De gustibus...  ;)


Inviato dal mio I-Sbronz utilizzando GrappaTalk.

 
https://gs1.wac.edgecastcdn.net/8019B6/data.tumblr.com/tumblr_kytkamL7Wq1qzxzwwo1_500.jpg
 
Va bene ammetto che nel fare esempi spesso ci metto un po' d'estro... :D
 
Pigon ha scritto:
Con questo metodo però quando lo lanci di nuovo ti richiederà se aggiornare all'ultimo update. Con il metodo di Karma non si ha questo inconveniente.

Si confermo , però per contro non si hanno due icone dell' eseguibile che appunto rimane quello originale, diciamo che come già detto giustamente ognuno decide di adottare la soluzione che preferisce tra quelle disponibili ;)

:)
 
Karma ha scritto:
In questa guida tratteremo il secondo metodo, più semplice, più veloce ed adatto a tutti gli utenti. (anche Viking ed Eircog)  :D

Ehmmm....confermo....è funzionato.  :)
 
...scusate ragazzi, siccome ho dovuto reinstallare il software mi dite precisamente la versione attuale utilizzata dal gruppo?  [:gossip]
 
Quando hai questi dubbi, leggi i topic che ci sono in bacheca... uno è proprio la versione

http://www.36stormovirtuale.net/Forum/index.php?topic=953.0

 
Domanda: ho la versione di DCS 1.2.10 (ufficiale). Se volessi installare il modulo del Sabre appena acquistato, devo per forza fare l'upgrade del mio DCS all'ultima versione, poi scaricarmi il Sabre (sempre ultima versione)e poi fare di nuovo il downgrade alla 1.2.10?

Per Black Shark ho dovuto fare così, anzi, senza contare che per questo ho dovuto installarlo prima da CD (si, ho la v1.0 del CD...), poi aggiornare DCS all'ultima versione, poi fare l'upgrade utilizzando questo: https://www.digitalcombatsimulator.com/en/downloads/modules/dcs_black_shark_2_upgrade/ e poi fare il downgrade alla versione ufficiale.

Che sbattimento...
 

Ultimi Messaggi

Indietro
Alto Basso